Question : Setting up a PPTP VPN Server in Cisco IOS.

I need some help setting up a vpn on a Cisco 827 ADSL router. I want the Cisco to be a PPTP/MPPE tunnel server (terminating the VPN) and use the Windows 2000 VPN client remotely. I have tried the following link (http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/dt_pptp.htm) but have not had any success. In fact, my router crashes when I try to attempt a connection!! Anyone see any problem with the configuration?

version 12.2                                                                    
no service pad                                                                  
service timestamps debug uptime                                                
service timestamps log uptime                                                  
no service password-encryption                                                  
!                                                                              
hostname Cisco827                                                              
!                                                                              
enable secret 5 ############                                  
enable password 7 ############                                              
!                                                                              
username ######### password 0 #########                                            
ip subnet-zero                                                                  
ip dhcp excluded-address 192.168.1.1 192.168.1.9                                
!                                                                              
ip dhcp pool dhcppool                                                          
   import all                                                                  
   network 192.168.1.0 255.255.255.0                                            
   default-router 192.168.1.1                                                  
   lease infinite                                                              
!                                                                              
ip dhcp-server 192.168.1.1                                                      
vpdn enable                                                                    
!                                                                              
vpdn-group 1                                                                        
! Default PPTP VPDN group                                                      
 accept-dialin                                                                  
  protocol pptp                                                                
  virtual-template 1                                                            
!                                                                              
vpdn-group pppoe                                                                
 request-dialin                                                                
  protocol pppoe                                                                
!                                                                              
interface Ethernet0                                                            
 ip address 192.168.1.1 255.255.255.0                                          
 ip nat inside                                                                  
 no ip mroute-cache                                                            
 hold-queue 100 out                                                            
!                                                                              
interface Virtual-Template1                                                    
 ip unnumbered Dialer1                                                          
 no ip redirects                                                                
 ip local-proxy-arp                                                            
 ip mroute-cache                                                                
 ppp authentication ms-chap                                                    
!                                                                              
interface ATM0                                                                  
 no ip address                                                                  
 no ip mroute-cache                                                            
 no atm ilmi-keepalive                                                          
 bundle-enable                                                                  
 dsl operating-mode auto                                                        
 hold-queue 224 in                                                              
!                                                                              
interface ATM0.1 point-to-point                                                
 ip access-group 110 in                                                        
 no ip mroute-cache                                                            
 pvc 8/35                                                                      
  pppoe-client dial-pool-number 1                                              
!                                                                              
interface Dialer1                                                              
 ip address negotiated                                                          
 ip mtu 1492                                                                    
 ip nat outside                                                                
 encapsulation ppp                                                              
 no ip mroute-cache                                                            
 dialer pool 1                                                                  
 no cdp enable                                                                  
 ppp pap sent-username ####### password 7 ##############    
 ppp ipcp dns request                                                          
!                                                                              
router rip                                                                      
 passive-interface Dialer1                                                      
 network 192.168.1.0                                                            
 network 0.0.0.0                                                                
!                                                                              
ip nat inside source list 1 interface Dialer1 overload                          
ip classless                                                                    
ip route 0.0.0.0 0.0.0.0 Dialer1                                                
ip http server                                                                  
!                                                                              
access-list 1 permit 192.168.0.0 0.0.255.255                                    
dialer-list 1 protocol ip list 100                                              
!                                                                              
line con 0                                                                      
 stopbits 1                                                                    
line vty 0 4                                                                    
 exec-timeout 0 0                                                              
 password 7 #############                                                  
 login                                                                          
!                                                                              
scheduler max-task-time 5000                                                    
end                                                                            

Answer : Setting up a PPTP VPN Server in Cisco IOS.

have a look at this url it explains pppoe but also ipsec

http://www.cisco.com/en/US/partner/tech/tk583/tk372/technologies_configuration_example09186a008009475c.shtml
Random Solutions  
 
programming4us programming4us