Question : Assigning different subnets on different switches

Hello all,
I want to implement DHCP in my environment because we are moving to Voice. I would like to deploy DHCP in a way it is easier to troubleshoot and easy in deployment. I want to know if the following is possible.

1. Deploy DHCP on per switch level. So any device that is connected to that particular switch will get the assigned IP from switch. So lets say Switch #3 has a subnet of 192.168.3.0, anything connected to this switch should get the IP from this subnet. Same should be set for Switch #4.
2. Is it possible with Microsoft DHCP server 2008 and how?
3. Is it better to use Cisco DHCP server and how?

Answer : Assigning different subnets on different switches

First and foremost enable IP routing on the devices:
config t
ip routing

Then setup your routing, I'm not sure what you use (OSPF, EIGRP) but it will look something like this:
config t
router eigrp 100 OR
router ospf 100
network 192.168.0.0 255.255.255.0

A Vlan will be setup like this: I'll use example network IP addresses.

config t
interface vlan 10
ip address 192.168.10.1
ip helper-address x.x.x.x - this is the address of your DHCP server, the vlan needs to know this to send it DHCP requests.

Then assign switch ports to the vlans
config t
interface ...
switchport mode access
switchport access vlan #
Random Solutions  
 
programming4us programming4us