Question : leap or peap or eap ?

Hi there,
I've a configuration given below on a Cisco 1240 access point. I have to document whether the AP is doing EAP or LEAP or PEAP authentication ? How do I know that which one is it doing from the configuration given below and attached image !  

Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
149:
150:
151:
152:
153:
154:
155:
156:
157:
158:
159:
160:
161:
162:
163:
164:
165:
166:
167:
168:
169:
170:
171:
172:
173:
174:
175:
176:
177:
178:
179:
180:
181:
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname xxx
!
enable secret 5 xxx
!
aaa new-model
!
!
aaa group server radius rad_eap
 server x.x.x.x auth-port 1645 acct-port 1646
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
 server x.x.x.x auth-port 1645 acct-port 1646
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local 
aaa accounting network acct_methods start-stop group rad_acct
!
aaa session-id common
!
resource policy
!
ip subnet-zero
no ip domain lookup
ip domain name xxx
!
!
!
dot11 ssid xxxxx
   vlan 17
   authentication open mac-address mac_methods eap eap_methods 
   authentication network-eap eap_methods 
   authentication key-management wpa
   guest-mode
!
dot11 ssid xxx
!
dot11 ssid xxxx
   authentication open 
!
dot11 ssid xxx
   authentication open eap eap_methods 
   authentication network-eap eap_methods 
   dot1x credentials Profile1
!
!
!
username xxx password 7 yyy
username xxx password 7 yyy
username xxx autocommand exit
 
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip 
 !
 encryption vlan 17 mode ciphers tkip 
 !
 ssid xx1
 !
 ssid xx2
 !
 ssid xx3
 !
 ssid xx4
 !
 speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio0.17
 encapsulation dot1Q 17 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 port-protected
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip 
 !
 encryption vlan 17 mode ciphers tkip 
 !
 ssid xxx
 !
 ssid xxx
 !
 no dfs band block
 speed  basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
 channel dfs
 station-role root
!
interface Dot11Radio1.17
 encapsulation dot1Q 17 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 port-protected
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 speed 100
 full-duplex
!
interface FastEthernet0.17
 encapsulation dot1Q 17 native
 no ip route-cache
 no snmp trap link-status
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address x.x.x.x
 ip helper-address x.x.x.x
 no ip route-cache
!
ip default-gateway x.x.x.x
ip http server
no ip http secure-server
ip radius source-interface BVI1 
 
radius-server local
  no authentication eapfast
  no authentication mac
  group GESBTR 
    block count 429496729 time infinite
  !
  group GESBRT 
    ssid xxx
  !
  user abc nthash 7 xxxxxxxxxxxxxxxxxxxxxx
!
radius-server attribute 32 include-in-access-req format %h
radius-server host x.x.x.x auth-port 1645 acct-port 1646 key 7 xxxxxxxxxxxxxxxxxxxxxxxxxx
radius-server vsa send accounting
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end

Answer : leap or peap or eap ?

Well according to the config that you have supplied then it would be EAP.

I hope this helps :)
Random Solutions  
 
programming4us programming4us