Question : Configuring VLAN on Catalyst 2948G -L3 Switch

Hi all,

I am attempted to configure 2 VLANS on a Catalyst 2948 -LG Switch.  The end result would be 2 seperate networks that could exchange data back and forth. I would plug a hub into 1 port of the switch (this would be network 1), and I would plug another hub into port 2 (this would be network 2). I know that I would also have to configure routing between the 2 VLANS, but I'll tackle that after I set up the 2 vlans

From the research I've done, I've tried some of the following commands:


20w0d: %SYS-5-CONFIG_I: Configured from console by console
Cat2948G-L3>en
Password:
Cat2948G-L3#show vlan

No Virtual LANs configured.

Cat2948G-L3#set vlan 10 name Network1
                ^
% Invalid input detected at '^' marker.

Cat2948G-L3#vlan 10
Translating "vlan"...domain server (255.255.255.255)
% Unknown command or computer name, or unable to find computer address
Cat2948G-L3#interface vlan 10
            ^
% Invalid input detected at '^' marker.

Cat2948G-L3#vlan ?
% Unrecognized command
Cat2948G-L3#vlan
Translating "vlan"...domain server (255.255.255.255)
% Unknown command or computer name, or unable to find computer address
Cat2948G-L3#set ?
% Unrecognized command

I don't understand what I'm doing wrong. I've also read that you have to configure vtp before configuing vlans and below are some of the commands I've typed:
Cat2948G-L3>en
Password:
Cat2948G-L3#set vtp domain Closet-10-01 mode transparent
                ^
% Invalid input detected at '^' marker.

Cat2948G-L3#show vtp domain
                  ^
% Invalid input detected at '^' marker.

I'm fairly new to Cisco switches and I would appreciate any help I can get.

Answer : Configuring VLAN on Catalyst 2948G -L3 Switch

You need to enter the "vlan " name in configuration mode, not enable mode.  To get into configuration mode, use the following commands:

Cat2948G-L3>en
Password:
Cat2948G-L3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Cat2948G-L3(config)#

You will then be in configuration mode and you can enter the vlan commands.

Cat2948G-L3(config)#vlan 10 name network1
Cat2948G-L3(config)#vlan 20 name network2

If you want to route between VLAN's, you'll need to use the "ip routing" global configuration command as well as create switch virtual interfaces and assign an IP address from each subnet to each SVI.

Cat2948G-L3>en
Password:
Cat2948G-L3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Cat2948G-L3(config)#interface vlan10
Cat2948G-L3(config)#ip address 192.168.10.1 255.255.255.0
Cat2948G-L3(config)#no shut
Cat2948G-L3(config)#interface vlan20
Cat2948G-L3(config)#ip address 192.168.20.1 255.255.255.0
Cat2948G-L3(config)#no shut
Cat2948G-L3(config)#exit
Cat2948G-L3(config)#ip routing

To assign the switch ports to the appropriate VLAN's, use the following commands:

Cat2948G-L3(config)#interface fa0/1
Cat2948G-L3(config)#switchport access vlan 10
Cat2948G-L3(config)#interface fa0/2
Cat2948G-L3(config)#switchport access vlan 20



Random Solutions  
 
programming4us programming4us