Microsoft
Software
Hardware
Network
Question : source based routing?
I have a router with multiple interfaces. I want to route to my next hop based on the source address. You can think of this as being a router at a small ISP with multiple Internet connections, but I only want to route certain customers over one of the connections.
interface BVI10
desc Internet connection
ip address 12.3.10.1 255.255.255.252
!
interface BVI11
desc - corporate network, devices on BVI12 and BVI13 should not route via here
ip address 1.1.2.1 255.255.255.252
!
interface BVI12
desc customer 1
ip address 2.3.10.1 255.255.255.240
!
interface BVI13
desc customer 2
ip address 2.3.11.1 255.255.255.240
!
interface BVI14
desc internal LAN
ip address 8.3.11.1 255.255.255.0
The corporate network uses public IP addresses, and of course I have my normal default route to get everything else to the Internet. I currently have a statement that just says
ip route 88.88.0.0 255.255.0.0 1.1.2.2
ip route 0.0.0.0 0.0.0.0 12.3.10.2
So all my traffic destined for corp-net goes over the BVI11 connection. How do I get my traffic from BVI12 and BVI13 to go over the normal internet connection, reguardless of destination, while traffic from BVI14 DOES go over the corp-net connection.
I thought a policy map would work here, but that would route all my outgoing traffic across a given connection, when I only want to route for a specific destination.
Answer : source based routing?
Policy route-map is your solution.
You define the source/destination pair with an access-list, then tell the router what to do with it
access-list 101 permit ip 2.3.11.0 0.0.0.255 any
access-list 101 permit ip 2.3.10.0 0.0.0.255 any
access-list 102 permit ip 8.3.11.0 0.0.0.255 any
route-map POLICY1 permit 10
match ip address 101
set ip next-hop 12.3.10.2
route-map POLICY2 permit 10
match ip address 102
set ip next-hop 1.1.2.2
Interface BVI11
ip policy route-map POLICY1
Interface BVI12
ip policy route-map POLICY1
Interface BVI14
ip policy route-map POLICY2
Random Solutions
Using pcAnywhere on Broadband.
DNS problems, 2003 servers
Autoconfiguration IP Address changes to APIPA(169.254.212...) after about 1 min VPN connection
sliding window protocol
Modify sendmail queued mail management
GPS Longitude and Latitude to City Names
Redundancy between two ISPs
How do create a new directory for Cisco background images?
Automatic DNS Registration for DHCP Clients?
Symantec Ghost 7.5, Windows XP, NO FLOPPY DRIVES