Question : Change Cisco Call Manager Express from Analog FXO lines to Integrated T1

We are purchasing a Voice and Data T1 with 9 trunk lines for voice.  We are currently running Cisco Call Manager Express on a Cisco 2811 router with 6 analog lines (FXO ports).  The main reason for changing our system is so that each person can have their own DID number.  

I have no idea how to even start connecting this system together, including setting up my new DIDs to dial in directly to each phone.  We currently have all phones ring whenever any call comes in.  Any sample configurations will help me out alot!
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
149:
150:
151:
152:
153:
154:
155:
156:
157:
158:
159:
160:
161:
162:
163:
164:
165:
166:
167:
168:
169:
170:
171:
172:
173:
174:
175:
176:
177:
178:
179:
180:
181:
182:
183:
184:
185:
186:
187:
188:
189:
190:
191:
192:
193:
194:
195:
196:
197:
198:
199:
200:
201:
202:
203:
204:
205:
206:
207:
208:
209:
210:
211:
212:
213:
214:
215:
216:
217:
218:
219:
220:
221:
222:
223:
224:
225:
226:
227:
228:
229:
230:
231:
232:
233:
234:
235:
236:
237:
238:
239:
240:
241:
242:
243:
244:
245:
246:
247:
248:
249:
250:
251:
252:
253:
254:
255:
256:
257:
258:
259:
260:
261:
262:
263:
264:
265:
266:
267:
268:
269:
270:
271:
272:
273:
274:
275:
276:
277:
278:
279:
280:
281:
282:
283:
284:
285:
286:
287:
288:
289:
290:
291:
292:
293:
294:
295:
296:
297:
298:
299:
300:
301:
302:
303:
304:
305:
306:
307:
308:
309:
310:
311:
312:
313:
314:
315:
316:
317:
318:
319:
320:
321:
322:
323:
324:
325:
326:
327:
328:
329:
330:
331:
332:
333:
334:
335:
336:
337:
338:
339:
340:
341:
342:
343:
344:
345:
346:
347:
348:
349:
350:
351:
352:
353:
354:
355:
356:
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VoipRouter
!
boot-start-marker
boot system flash c2800nm-spservicesk9-mz.123-14.T7.bin
boot-end-marker
!
logging buffered 99999 debugging
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 10
clock timezone PDT -8
clock summer-time PDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
no network-clock-participate wic 2 
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.1.1 10.0.1.100
ip dhcp excluded-address 10.0.1.150 10.0.1.254
ip dhcp excluded-address 10.0.100.100 10.0.100.254
!
ip dhcp pool phone
   network 10.0.100.0 255.255.255.0
   default-router 10.0.100.1 
   option 150 ip 10.0.100.1 
!
ip dhcp pool clients
   network 10.0.1.0 255.255.255.0
   default-router 10.0.1.2 
   domain-name .com
   dns-server 10.0.1.89 
   netbios-name-server 10.0.1.89 
   netbios-node-type h-node
!
no ftp-server write-enable
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 no supplementary-service h450.2
 no supplementary-service h450.3
 supplementary-service h450.12
!
controller T1 0/2/0
 description point to point
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/2/1
 framing esf
 linecode b8zs
 description WHAT DO I DO HERE
!
interface FastEthernet0/0
 description Connecteted to Catalyst port 0/1 data VLAN for PCs and DHCP server
 ip address 10.0.50.1 255.255.255.0
 duplex full
 speed 100
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 10.0.1.3 255.255.255.0
 no snmp trap link-status
!
interface FastEthernet0/0.100
 description $ETH-LAN$
 encapsulation dot1Q 100
 ip address 10.0.100.1 255.255.255.0
 no snmp trap link-status
!
interface Service-Engine0/0
 ip unnumbered FastEthernet0/0.100
 service-module ip address 10.0.100.2 255.255.255.0
 service-module ip default-gateway 10.0.100.1
!
interface FastEthernet0/1
 ip address 192.168.70.1 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface Serial0/2/0:0
 ip address 10.99.99.1 255.255.255.252
 encapsulation ppp
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.1.1
ip route 10.0.100.2 255.255.255.255 Service-Engine0/0
ip route 10.1.1.0 255.255.255.0 10.0.1.1
ip route 10.5.0.0 255.255.0.0 10.99.99.2
ip route 10.11.1.0 255.255.255.0 10.99.99.2
ip route 192.168.70.0 255.255.255.0 10.0.1.2
!
ip http server
no ip http secure-server
ip http path flash:
!
access-list 102 remark SDM_ACL Category=1
access-list 102 permit ip any 10.1.1.0 0.0.0.255
!
tftp-server flash:CP7905040000SCCP040701A.sbin
tftp-server flash:cmterm_7936.3-3-5-0.bin
tftp-server flash:P00303020214.bin
tftp-server flash:P00305000301.sbn
tftp-server flash:RingList.xml
tftp-server flash:Analog1.raw
tftp-server flash:Bass.raw
tftp-server flash:Chime.raw
tftp-server flash:Jamaica.raw
tftp-server flash:Pop.raw
!
control-plane
!
voice-port 0/0/0
 timeouts interdigit 3
 connection plar 0000
 caller-id enable
!
voice-port 0/0/1
 timeouts interdigit 3
 connection plar 0001
 caller-id enable
!
voice-port 0/0/2
 timeouts interdigit 3
 connection plar 0002
 caller-id enable
!
voice-port 0/0/3
 timeouts interdigit 3
 connection plar 0003
 caller-id enable
!
voice-port 0/1/0
 timeouts interdigit 3
 connection plar 0004
 caller-id enable
!
voice-port 0/1/1
 timeouts interdigit 3
 connection plar 0005
 caller-id enable
!
voice-port 0/1/2
 shutdown
!
voice-port 0/1/3
 shutdown
!
!
dial-peer voice 2 pots
 destination-pattern A0
 port 0/0/0
!
dial-peer voice 3 pots
 destination-pattern A1
 port 0/0/1
!
dial-peer voice 4 pots
 destination-pattern A2
 port 0/0/2
!
dial-peer voice 5 pots
 destination-pattern A3
 port 0/0/3
!
dial-peer voice 50 voip
 description ** cue voicemail pilot number **
 destination-pattern 6000
 session protocol sipv2
 session target ipv4:10.0.100.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 51 voip
 destination-pattern 6001
 session protocol sipv2
 session target ipv4:10.0.100.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 6 pots
 destination-pattern 9T
 port 0/0/0
!
dial-peer voice 7 pots
 destination-pattern 9T
 port 0/0/1
!
dial-peer voice 8 pots
 destination-pattern 9T
 port 0/0/2
!
dial-peer voice 9 pots
 destination-pattern 9T
 port 0/0/3
!
dial-peer voice 60 pots
 destination-pattern AAAA
 incoming called-number 000.
!
dial-peer voice 10 pots
 destination-pattern A4
 port 0/1/0
!
dial-peer voice 11 pots
 destination-pattern A5
 port 0/1/1
!
dial-peer voice 14 pots
 destination-pattern 9T
 port 0/1/0
!
dial-peer voice 15 pots
 destination-pattern 9T
 port 0/1/1
!
!
!
telephony-service
 fxo hook-flash
 load 7960-7940 P00305000301
 load 7905 CP7905040000SCCP040701A
 load 7936 cmterm_7936.3-3-5-0
 max-ephones 36
 max-dn 108
 ip source-address 10.0.100.1 port 2000
 auto assign 20 to 36
 timeouts interdigit 3
 system message voipsystem
 time-zone 5
 create cnf-files version-stamp 7960 Feb 13 2008 18:50:29
 voicemail 6001
 max-conferences 8 gain 3
 call-forward pattern .T
 moh music-on-hold.au
 web admin system name admin secret 5 $$$$$$
 dn-webedit 
 time-webedit 
 transfer-system full-blind
 transfer-pattern .T
 secondary-dialtone 9
!
!
ephone-template  1
 softkeys idle  Redial Newcall Cfwdall Dnd Pickup Gpickup
 softkeys seized  Redial Cfwdall Endcall Gpickup Pickup
 softkeys alerting  Callback Endcall
 softkeys connected  Hold Trnsfer Confrn Endcall
!
!ephone-dn  1
 number 4001
 label 4001
 description USER1
 name USER1
 call-forward busy 6001
 call-forward noan 6001 timeout 10
 hold-alert 30 originator
!
!
ephone-dn  2
 number 0000
 label CO Line 1
 name Line1
 call-forward busy 6000
 call-forward noan 6000 timeout 15
 trunk A0
!
!
ephone-dn  3
 number 0001
 label CO Line 2
 name Line2
 call-forward busy 6000
 call-forward noan 6000 timeout 15
 trunk A1
!
!
ephone-dn  4
 number 0002
 label CO Line 3
 name Line3
 call-forward busy 6000
 call-forward noan 6000 timeout 15
 trunk A2
!
!
ephone-dn  5
 number 0003
 label CO Line 4
 name Line4
 call-forward busy 6000
 call-forward noan 6000 timeout 15
 trunk A3
!
!
ephone-dn  6
 number 0004
 label CO Line 5
 name Line5
 call-forward busy 6000
 call-forward noan 6000 timeout 15
 trunk A4
!
!
ephone-dn  7
 number 0005
 label CO Line 6
 name Line6
 call-forward busy 6000
 call-forward noan 6000 timeout 15
 trunk A5
!
!
ephone-dn  8  dual-line
 number 4002 
 label 4002
 description USER2
 name USER2
 call-forward busy 6001
 call-forward noan 6001 timeout 10
!
!
ephone  1
 description USER1 desk
 ephone-template 1
 mac-address x.x.x.x
 type 7940
 auto-line incoming
 button  1:1 2o2,3,4,5,6,7
!
 
ephone  2
 description USER2 desk
 ephone-template 1
 mac-address y.y.y.y
 type 7940
 auto-line incoming
 button  1:8 2o2,3,4,5,6,7
!

Answer : Change Cisco Call Manager Express from Analog FXO lines to Integrated T1

we will remove first 4 digits from 3270-3329
use this configuration

voice translation-rule 1
rule 1 /3270/ //

voice translation-profile VGW-IN
translate called 1

dial-peer voice 1 pots
incoming called-number .
direct-inward-dial
port x/x/x:x
translation-profile incoming VGW-IN

dial-peer voice 2 pots
destination-pattern 9T
port x/x/x:x

using this configuration you will receive the calls to the extension that will match last 4 digits.
try it and update me please.

Best,
Hussam
Random Solutions  
 
programming4us programming4us