Microsoft
Software
Hardware
Network
Question : Setup VWIC 1MFT T1 for Call Manager Express
I have a huge mess here. I am trying to setup call manager express. I cannot figure out how to configure the VWIC-1MFT card,
amongst other problems.
The ISP has a Cisco IAD2431-1T1E1.
Their connection comes into Port T1/E1 1/0
They say the PRI line is Port T1/E1 1/1 and that I need to plug into that port with a straight through patch cable
I connected the FastEthernet 0/0 to the GE 0/0 port on my 2821 router and the data is working.
The ISP gave me a info sheet with the settings. It says:
Dialing:
Line Signaling:
Framing: ESF
Coding: B8ZS
ISDN Signaling: NI2
Digits pulsed: 4
I also used the CME quick config tool. Only one phone will register. All of the other phones say "TFTP file not found" I
have tried pressing every button on the phone when it is booting but nothing will allow me to get to the settings.
Below is my attempt at configuring the VWIC card. Any help is greatly appreciated and much needed. thanks.
--------------------------
----------
----------
----------
----------
----------
----------
----------
---
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CCME
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 ---------
!
no aaa new-model
!
resource policy
!
clock timezone GMT -6
clock summer-time GMT recurring
no network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.2.1 10.0.2.10
ip dhcp excluded-address 10.0.1.1 10.0.1.12
!
ip dhcp pool phone
network 10.0.2.0 255.255.255.0
default-router 10.0.2.1
option 150 ip 10.0.2.1
!
ip dhcp pool data
network 10.0.1.0 255.255.255.0
default-router 10.0.1.1
dns-server 66.xx.9x.xxx 64.x.xxx.xx
!
!
ip domain name yourdomain.com
ip name-server 66.xx.9x.xxx
ip name-server 64.x.xxx.xx
isdn switch-type primary-ni
!
voice-card 0
no dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
h323
sip
registrar server expires max 3600 min 3600
!
!
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
voice translation-rule 9
rule 1 /^911$/ /911/
rule 2 /^9\(.*\)/ /\1/
!
!
!
crypto pki trustpoint TP-self-signed-972079041
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certifi
cate-97207
9041
revocation-check none
rsakeypair TP-self-signed-972079041
!
!
crypto pki certificate chain TP-self-signed-972079041
certificate self-signed 01
3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 39373230 37393034 31301E17 0D303730 32323832 30343033
365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3937 32303739
30343130 819F300D 06092A86 4886F70D 01010105 0003818D 00308189
C83395BD 0AA14A25 408E4E9C 9FF2B141 79279357 56C93AA0 26023DD7 7406CC94
9B0EF9C1 C6A26B4F 577B0301 2B1DC654 F0D921C2 D6B8FB66 2A2868B5 278D77CD
90420128 44CF3678 A1496247 242F4E0F 88685E78 5E38782A B78DF1D7 2766EC3A
34D68624 D965EA17 BCAFC53E F4339F12 E10CC540 ABF6084F 6349A6E8 158CC761
02030100 01A37730 75300F06 03551D13 0101FF04 05300301 01FF3022 0603551D
11041B30 19821779 6F75726E 616D652E 796F7572 646F6D61 696E2E63 6F6D301F
0603551D 23041830 16801438 F8BC7318 DAC44631 CD41F749 34DE3639 0EC4CC
1D060355 1D0E0416 041438F8 BC7318DA C44631CD 41F74934 DE36390E C4CC300D
06092A86 4886F70D 01010405 00038181 0017524B 5B15453E 425D9E33 B367D474
8CC9C9BF 7DD8D855 5A142A00 DDD6F074 179140F5 A41FE908 BFCF56ED 67F3EDA1
73159FFA 72712EE3 B0CE1F22 17A3D4EC 75BFF35D 9E74F048 B41F2D01 09F99EED
41B61EEA 2C606C2A 982DFFFD 611F3E1C D6046AD8 D67A9DC9 62EC23AB 3DE81BEB
B5771918 4AC96A0D 1C0C65DD 1D2D2C7F 6F
quit
!
!
controller T1 0/0/0
framing
linecode b8zs
channel-group 0 timeslots 1-24
!
class-map match-all L3-to-L2_VoIP-Cntrl
match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
match ip dscp ef
class-map match-all SIP
match protocol sip
class-map match-all RTP
match protocol rtp
!
!
policy-map EthOut
class RTP
policy-map output-L3-to-L2
class L3-to-L2_VoIP-RTP
set cos 5
class L3-to-L2_VoIP-Cntrl
set cos 3
!
!
!
!
interface Loopback0
ip address 10.1.10.2 255.255.255.0
!
interface GigabitEthernet0/0
ip address
255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface GigabitEthernet0/1.100
description ** Data VLAN **
encapsulation dot1Q 100 native
ip address 10.0.1.1 255.255.255.0
ip nat inside
no snmp trap link-status
!
interface GigabitEthernet0/1.200
description ** Voice VLAN **
encapsulation dot1Q 200
ip address 10.0.2.1 255.255.255.0
ip nat inside
no snmp trap link-status
service-policy output output-L3-to-L2
!
interface Serial0/0/0:0
no ip address
no logging event link-status
!
interface Serial0/2/0
no ip address
no logging event link-status
shutdown
!
interface Service-Engine1/0
ip unnumbered Loopback0
service-module ip address 10.1.10.1 255.255.255.0
service-module ip default-gateway 10.1.10.2
!
ip classless
ip route 0.0.0.0 0.0.0.0
ip route 10.1.10.1 255.255.255.255 Service-Engine1/0
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
ip nat pool poolone
netmask 255.255.255.252
ip nat inside source route-map nonat pool poolone overload
!
access-list 23 permit 10.10.10.0 0.0.0.7
route-map nonat permit 10
!
!
!
tftp-server flash:P00307020200.sbn
tftp-server flash:P00307020200.bin
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
dial-peer cor custom
name internal
name local
name domestic
name international
name 900
name 976
!
!
dial-peer cor list call-internal
member internal
!
dial-peer cor list call-local
member local
!
dial-peer cor list call-domestic
member domestic
!
dial-peer cor list call-international
member international
!
dial-peer cor list call-900
member 900
!
dial-peer cor list call-976
member 976
!
dial-peer cor list user-internal
member internal
!
dial-peer cor list user-local
member internal
member local
!
dial-peer cor list user-domestic
member internal
member local
member domestic
!
dial-peer cor list us
member internal
member local
member domestic
member international
!
dial-peer cor list user900-internal
member internal
member 900
member 976
!
dial-peer cor list user900-local
member internal
member local
member 900
member 976
!
dial-peer cor list user900-domestic
member internal
member local
member domestic
member 900
member 976
!
dial-peer cor list user900-international
member internal
member local
member domestic
member international
member 900
member 976
!
!
dial-peer voice 2 voip
description ** cue voicemail pilot number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 6000
session protocol sipv2
session target ipv4:10.1.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 3 voip
description ** cue auto attendant number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 6011
session protocol sipv2
session target ipv4:10.1.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
!
!
telephony-service
load 7960-7940 P0030702020
max-ephones 48
max-dn 96
ip source-address 10.0.2.1 port 2000
calling-number initiator
system message Acme Co.
time-zone 8
create cnf-files version-stamp 7960 Feb 28 2007 12:31:42
voicemail 6000
max-conferences 8 gain -6
call-forward pattern .T
moh music-on-hold.au
dn-webedit
time-webedit
transfer-system full-consult dss
transfer-pattern 9.T
secondary-dialtone 9
!
Answer : Setup VWIC 1MFT T1 for Call Manager Express
Thanks for the input. Actually the VWIC problem was that the ISP side was not configured correctly. Once they got it, I configured the VWIC with pri-group timeslots 1-6,24 and it worked fine.
The other issue of the phones not registering, I actaully ended up calling Cisco tech support. The .loads, .sb2, and .bin files were corrupted on the router. When we replaced those files the phones registered.
I am going to request to have this question deleted if that is ok.
thanks.
Random Solutions
AIX 4.3.3 routing tables
SMTP can't connect to dns, unable to bind to the destination server
Adding computer to existing small network with switch and 2 computers
Two nics
System Engineers
newsletter setup
How To Port Forward using SMC8014 for TightVNC
Configure 2 Gateways in Windows XP
Eclipse: How to enable "link with"? (active editor and the tree in Project Explorer)
NAT and IPSec endpoint on a Cisco router