Question : HELP understanding config for Verizon SIP IP trunking (VOIP)

ip subnet-zero
ip cef
ip domain-name ALTER.NET
ip name-server  primaryDNS
ip name-server  secondary DNS
ip name-server  Tertiary DNS
voice service pots
fax rate voice
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
! *** Only for Managed Customers ****
call-history-mib retain-timer 500
call-history-mib max-size 500
dial-control-mib retain-timer 1000
dial-control-mib max-size 500
!
interface Multilink 3003
bandwidth 3072
! 2 x 1536 =3072 bandwidth for 2 T1s
ip address a.b.c.d e.f.g.h
no ip redirects
no ip proxy-arp
max-reserved-bandwidth 100
service-policy output PIP_ADVANTAGE
no ip mroute-cache
no peer neighbor-route
no cdp enable
ppp multilink
ppp multilink fragment disable
ppp multilink group 3003
!
interface GigabitEthernet0/0
ip address 192.168.30.1 255.255.255.0
duplex full
speed 100
no cdp enable
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex full
speed auto
no cdp enable
card type T1 0 0
controller T1 0/0/0
framing esf
linecode b8zs
channel-group 1 timeslots 1-24 speed 64
controller t1 0/0/1
framing esf
linecode b8zs
channel-group 1 timeslots 1-24 speed 64
interface Serial 0/0/0:1
bandwidth 1536
no ip address
no ip redirects
max-reserved-bandwidth 90
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 3003
!
interface Serial 0/0/1:1
bandwidth 1536
no ip address
no ip redirects
max-reserved-bandwidth 90
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 3003
ip route 0.0.0.0 0.0.0.0 multilink 3003
voice service voip
fax protocol none
sip
bind control source-interface multilink 3003
bind media source-interface multilink 3003
rel1xx disable
isdn switch-type   primary-ni
! 1 PBX T1 0/1/0 2 PBX T1 0/1/1
Card type T1 0 1
controller T1 0/1/0
framing  esf
clock source  line
linecode  b8zs
cablelength  short 133
pri-group timeslot 1-24
!
!
interface serial 0/1/0:23
no ip address
no logging event link-status
isdn timer t321 30000
isdn incoming-voice voice
isdn guard-timer 1000
isdn send-alerting
! "isdn protocol-emulate network" should be used if clock source is internal, if not, just leave this line blank
no fair-queue
no cdp enable
! 1 PBX T1 0/1/0:23 2 PBX T1 0/1/1:23
voice-port  0/1/0:23
busyout action shutdown
busyout monitor  Serial0/#/# for combo, FastEthernet0/0 for gateway, Busyout is not supported for Multilink
playout-delay maximum 120
playout-delay nominal 15
playout-delay minimum low
echo-cancel enable
no non-linear
mgcp  profile default
!
!
voice translation-rule 1
rule 1 /.*/ /\1234567899/
voice translation-rule 2
rule 1 // /101\0/
voice translation-rule 3
rule 1 /^101\(.*\)/ /\1/
voice translation-rule 4
rule 1 /^1015\(.*\)/ /\1/
! Variable "5" is an access digit for fax
voice translation-profile prepend
translate called 2
voice translation-profile rpid
translate calling 1
voice translation-profile strip
translate calling 1
translate called 3
voice translation-profile strip2
translate calling 1
translate called 4
!
class-map match-any Gold
match dscp cs5 ef
match access-group 140
class-map match-any AF4
match dscp cs4 af41 af42 af43
!
class-map match-any AF3
match  dscp cs3  af31  af32  af33  cs6  cs7
!
class-map match-any AF2
match dscp cs2 af21 af22 af23
match access-group 142
policy-map PIP_ADVANTAGE
class Gold
priority  x
!
class AF4
bandwidth remaining percent 40
random-detect
!
class AF3
bandwidth remaining percent 40
random-detect
!
class AF2
bandwidth remaining percent 16
random-detect
!
class class-default
bandwidth remaining percent 4
random-detect
access-list 140 permit udp any any tos 5
access-list 142 permit tcp any any eq pop3
access-list 142 permit tcp any eq pop3 any
access-list 142 permit udp any any eq 2049
access-list 142 permit udp any eq 2049 any
access-list 142 permit tcp any any eq www
access-list 142 permit tcp any eq www any
access-list 142 permit tcp any any eq ftp-data
access-list 142 permit tcp any eq ftp-data any
access-list 142 permit tcp any any eq ftp
access-list 142 permit tcp any eq ftp any
access-list 142 permit udp any any eq domain
access-list 142 permit udp any eq domain any
access-list 142 permit tcp any any eq 3306
access-list 142 permit tcp any eq 3306 any
no cdp advertise-v2
no cdp run
dial-peer  voice 100 voip
description originating voip dial peer
translation-profile outgoing strip
destination-pattern 101.T
rtp  payload-type cisco-codec-fax-ack 114
rtp  payload-type cisco-codec-fax-ind 113
rtp  payload-type nte 98
voice-class  codec 1
session protocol  sipv2
session target sip-server
dtmf-relay  rtp-nte
fax rate voice
ip qos  dscp cs5 media
ip qos  dscp cs3 signaling
no vad
!
dial-peer  voice 200 voip
description terminating voip dial peer
incoming called-number  .T
rtp payload-type  cisco-codec-fax-ack 114
rtp payload-type  cisco-codec-fax-ind 113
rtp payload-type  nte 98
voice-class  codec 1
session protocol  sipv2
session target sip-server
dtmf-relay  rtp-nte
fax rate voice
ip qos  dscp cs5 media
ip qos  dscp cs3 signaling
no vad
! *********************************************************
! Dial peer 300 voip is the originating dial peer for fax
dial-peer  voice 300 voip
translation-profile outgoing strip2
destination-pattern 1015.T
! "5" must match translation rule 4 variable
rtp payload-type  cisco-codec-fax-ack 114
rtp payload-type  cisco-codec-fax-ind 113
rtp payload-type  nte 98
session protocol  sipv2
session target sip-server
dtmf-relay  rtp-nte
codec g711ulaw
fax rate disable
ip qos  dscp cs5 media
ip qos  dscp cs3 signaling
no vad
!
! Dial peer 400 voip is the terminating dial peer for fax
dial-peer  voice 400 voip
rtp payload-type  cisco-codec-fax-ack 114
rtp payload-type  cisco-codec-fax-ind 113
rtp payload-type  nte 98
session protocol  sipv2
session target sip-server
incoming called-number wxyz
dtmf-relay  rtp-nte
codec g711ulaw
fax rate disable
ip qos  dscp cs5 media
ip qos  dscp cs3 signaling
no vad
dial-peer  voice 10 pots
translation-profile incoming prepend
progress_ind alert strip 8
destination-pattern .T
direct-inward-dial
port 0/1/0:23 (Use 0/2/0:23 for all NxT1 WAN MLPPP configurations)
!
sip-ua
set sip-status 400 pstn-cause 31
set sip-status 401 pstn-cause 21
set sip-status 403 pstn-cause 21
set sip-status 405 pstn-cause 63
set sip-status 406 pstn-cause 79
set sip-status 410 pstn-cause 22
set sip-status 488 pstn-cause 31
set sip-status 501 pstn-cause 38
set sip-status 503 pstn-cause 41
set sip-status 606 pstn-cause 38
set pstn-cause 6 sip-status 406
set pstn-cause 27 sip-status 502
set pstn-cause 30 sip-status 501
set pstn-cause 31 sip-status 480
set pstn-cause 43 sip-status 502
set pstn-cause 44 sip-status 503
set pstn-cause 49 sip-status 503
set pstn-cause 50 sip-status 503
set pstn-cause 58 sip-status 503
set pstn-cause 63 sip-status 503
set pstn-cause 66 sip-status 480
set pstn-cause 69 sip-status 503
set pstn-cause 70 sip-status 503
set pstn-cause 81 sip-status 502
set pstn-cause 82 sip-status 502
set pstn-cause 83 sip-status 503
set pstn-cause 84 sip-status 503
set pstn-cause 85 sip-status 503
set pstn-cause 86 sip-status 408
set pstn-cause 88 sip-status 503
set pstn-cause 91 sip-status 502
set pstn-cause 95 sip-status 503
set pstn-cause 96 sip-status 409
set pstn-cause 97 sip-status 480
set pstn-cause 98 sip-status 409
set pstn-cause 99 sip-status 480
set pstn-cause 100 sip-status 501
set pstn-cause 101 sip-status 503
set pstn-cause 111 sip-status 500
retry  invite 2
retry  cancel 2
retry  bye 2
sip-server  dns:x.globalipcom.com
g729-annexb override
!
!
line con 0
exec-timeout 30 0
logging synchronous
password  x
login
stopbits 1
line aux 0
password  x
login
stopbits 1
line vty 0 4
session-timeout 30
exec-timeout 30 0
password  x
login
ntp server "ip address" version 1
end
!
!

Answer : HELP understanding config for Verizon SIP IP trunking (VOIP)

okay so lets start with some of the basics then. this config has both IP configuation and SIP stuff in it.

ip cef
ip domain-name ALTER.NET
ip name-server  primaryDNS
ip name-server  secondary DNS
ip name-server  Tertiary DNS

interface Multilink 3003
bandwidth 3072
! 2 x 1536 =3072 bandwidth for 2 T1s
ip address a.b.c.d e.f.g.h
no ip redirects
no ip proxy-arp
max-reserved-bandwidth 100
service-policy output PIP_ADVANTAGE
no ip mroute-cache
no peer neighbor-route
no cdp enable
ppp multilink
ppp multilink fragment disable
ppp multilink group 3003

this stuff is just setting up the IP connection and some of the underlying services like DNS

codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw

this is for your codec preferences so by default you're looking at using G.729 as the default codec. This is compressed voice and takes up less bandwidth than the other codecs but faxes and other analog devices won't work with a compressed call so you need support for G.711 (u law in particular) for things like fax machines


class-map match-any Gold
match dscp cs5 ef
match access-group 140
class-map match-any AF4
match dscp cs4 af41 af42 af43
!
class-map match-any AF3
match  dscp cs3  af31  af32  af33  cs6  cs7
!
class-map match-any AF2
match dscp cs2 af21 af22 af23
match access-group 142
policy-map PIP_ADVANTAGE
class Gold
priority  x
!
class AF4
bandwidth remaining percent 40
random-detect
!
class AF3
bandwidth remaining percent 40
random-detect
!
class AF2
bandwidth remaining percent 16
random-detect
!
class class-default
bandwidth remaining percent 4
random-detect
access-list 140 permit udp any any tos 5
access-list 142 permit tcp any any eq pop3
access-list 142 permit tcp any eq pop3 any
access-list 142 permit udp any any eq 2049
access-list 142 permit udp any eq 2049 any
access-list 142 permit tcp any any eq www
access-list 142 permit tcp any eq www any
access-list 142 permit tcp any any eq ftp-data
access-list 142 permit tcp any eq ftp-data any
access-list 142 permit tcp any any eq ftp
access-list 142 permit tcp any eq ftp any
access-list 142 permit udp any any eq domain
access-list 142 permit udp any eq domain any
access-list 142 permit tcp any any eq 3306
access-list 142 permit tcp any eq 3306 any

this is mostly QOS stuff, the Default class there is setting up your ACL's for data

let's start with that. If that stuff makes sense, we'll go through some of the other stuff like the translations. If not, let me know what parts of this need more description or clarification.
Random Solutions  
 
programming4us programming4us