Question : Adtran Netvanta 3448 QoS with Mitel Phones

Configuring a new Netvanta 3448 router for QoS.

This site connects back to the hub via a T1 link running MPLS.  I know that the provider is setup for QoS over MPLS, although I have not yet confirmed if/what DSCP markings they are looking for - if any.

What I want to verify right now:
Am I running QoS properly? Am I prioritizing voice and control over all other data?  
When I plug my Mitel phone in, it does properly pick up a DHCP IP in the VOICE VLAN (vlan 3).  When I make a phone call while downloading, though, voice quality is terrible.  

I'm new to QoS, so more than anything, I'm just wondering if I'm missing anything.

Thanks!
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
!
!
!
ip dhcp-server excluded-address 10.10.10.1 10.10.10.29
ip dhcp-server excluded-address 10.20.10.1 10.20.10.29
!
ip dhcp-server pool "DATA"
  network 10.10.10.0 255.255.255.0
  dns-server 10.10.1.12 10.10.1.14 10.10.1.16
  default-router 10.10.10.1
!
ip dhcp-server pool "VOICE"
  network 10.20.10.0 255.255.255.0
  default-router 10.20.10.1
  option 128 ip X.X.X.X
  option 129 ip X.X.X.X
  option 130 ascii XXXX
!
!
!
!
!
!
qos map ppp1QosWizard 20
  match list aclppp1QosWizRTP20
  priority 300
  set dscp 26
qos map ppp1QosWizard 21
  match list aclppp1QosWizSignal21
  set dscp 26
!
!
!
!
vlan 1
  name "Default"
!
vlan 2
  name "DATA"
!
vlan 3
  name "VOICE"
!
!
!
no ethernet cfm
!
!
!
!
interface switchport 0/1
  no shutdown
!
interface switchport 0/2
  no shutdown
!
interface switchport 0/3
  no shutdown
!
interface switchport 0/4
  no shutdown
!
interface switchport 0/5
  no shutdown
!
interface switchport 0/6
  spanning-tree edgeport
  no shutdown
  switchport voice vlan 3
!
interface switchport 0/7
  no shutdown
!
interface switchport 0/8
  no shutdown
!
!
!
interface vlan 1
  description Data VLAN
  ip address  10.10.10.1  255.255.255.0
  no shutdown
!
interface vlan 3
  description Voice VLAN
  ip address  10.20.10.1  255.255.255.0
  no shutdown
!
!
interface t1 1/1
  description MPLS-T1
  fdl none
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
interface ppp 1
  ip address  X.X.X.X  255.255.255.252
  media-gateway ip primary
  qos-policy out ppp1QosWizard
  no shutdown
  cross-connect 1 t1 1/1 1 ppp 1
!
!
!
!
!
!
!
ip access-list standard NATLIST
  permit any
!
!
ip access-list extended aclppp1QosWizRTP20
  permit ip 10.20.10.0 0.0.0.255  any
!
ip access-list extended aclppp1QosWizSignal21
  permit udp any  any eq 5060
  permit tcp any  any eq 5060
!
ip access-list extended NONAT
  permit ip 10.10.10.0 0.0.0.255  10.0.0.0 0.255.255.255
!
ip access-list extended OUTSIDE_IN
  permit icmp any  any
  permit tcp any  any eq ssh
  permit ip any  any
!
ip access-list extended self
  permit ip any  any     log
!
!
ip policy-class INSIDE
  allow list NONAT stateless
  allow list self self
  nat source list NATLIST interface eth 0/1 overload
!
ip policy-class OUTSIDE
  allow reverse list NONAT stateless
  allow list OUTSIDE_IN
!
!
!
ip route 0.0.0.0 0.0.0.0 X.X.X.X
!

Answer : Adtran Netvanta 3448 QoS with Mitel Phones

okay so a couple things

qos map ppp1QosWizard 20
  match list aclppp1QosWizRTP20
  priority 300
  set dscp 26
qos map ppp1QosWizard 21
  match list aclppp1QosWizSignal21
  set dscp 26

the priority 300 line means you're only prioritizing 300 kbps for RTP traffic and none for signalling
depending on how the T1 is setup you may want to prioritize by percent. But those settings will have to come from your provider. if the voice is going through an MPLS cloud with QOS prioritization then the way you tag packets at the phone (the DSCP values) will have to match the MPLS providers settings. Usually the DSCP values are different for RTP and signal so your set dscp 26 line may be differet for signal.

you'll need to check with your provider on what marking to use and what amount of bandwidth can be prioritized. if your RTP bandwidth goes above 300 kpbs (in your current config) then all calls will suffer because all of the RTP sessions are subject to the same priority queue.

if you're using a 3448 you might also want to check on POE adapter for the IP phones so you don't need external AC power and/or Adtrans enhanced feature package if you need to do something like an IPSec VPN tunnel
Random Solutions  
 
programming4us programming4us