Question : Cisco 837 - Strange Issue When Connecting Via DSL

Hi all,

I have just set-up a Cisco 837 for DSL using Orange in the UK and I have a strange issue.

When I connect any machine to the device via Fast Ethernet it is allocated an IP address from DHCP and also receives the DNS Server information.

When I then open a browser (Internet Explorer or Firefox) I am able to reach Google and perform searches, however if I try to get to other websites - for example bbc.co.uk, or any link provided by google as a search result they simply fail to load. What is strange that occasionally I can get to digg.com for example but this is hit and miss.

I have upgraded the device to the latest IOS and reconfigured it twice with no improvement. The strange this is I use a very simular configuration on a CIsco 877W and it works a charm, no issues.

See below for my configuration: -

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxx
!
no aaa new-model
!
!
no ip dhcp use vrf connected
!
ip dhcp pool LAN
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 193.36.79.101 193.36.79.100
!
!
ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username mswbull privilege 15 password 7 xxxxxxxxxxx
!
!
!
!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 hold-queue 100 out
!
interface Ethernet2
 no ip address
 shutdown
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet3
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet4
 shutdown
 duplex auto
 speed auto
!
interface Dialer0
 description Orange ADSL
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxxxxxxxxxx
 ppp chap password 7 xxxxxxxxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer0 overload
!
access-list 1 permit any
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
 password 7 xxxxxxxxxxx
 login
 no modem enable
line aux 0
line vty 0 4
 password 7 xxxxxxxxxxx
 login
!
scheduler max-task-time 5000
end
 

Answer : Cisco 837 - Strange Issue When Connecting Via DSL

HI all,

Just to let you know I have resolved the issue. It was to do with the MTU size.

The following commands were added: -

interface Ethernet0
   ip tcp adjust-mss 1452

interface Dialer0
   ip mtu 1492

Everything is now working as expected.

Thanks for your support with this issue.
Random Solutions  
 
programming4us programming4us