Microsoft
Software
Hardware
Network
Question : Catalyst 3560G VLANs, IP Helper-Address, and Windows DHCP Servers
I have four VLANs with them being as follows:
1 CompanyA
2 Voice
20 CompanyB
21 CompanyC
I have a DHCP server on CompanyA and a DHCP server on CompanyB
I have a PC plugged into an IP phone that is plugged into interface
GigabitEthernet0/29. The reason it is in trunk mode because we have an IP phone
in front of the PC. The PC is using DHCP to obtain an IP address and it is
supposed to be on VLAN 1. For some reason it is pulling an IP from the DHCP
server from CompanyB on VLAN 20. Interface GigabitEthernet0/1 is plugged into
another switch that has CompanyA's DHCP server. Interface
GigabitEthernet0/49 is plugged into another switch that has CompanyB's
DHCP server. My question is why is it pulling an IP from CompanyB's DHCP
server when the interface gig0/29 is set to be a native vlan 1 trunk? My
running config is below.
Building configuration...
Current configuration : 4609 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/5
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet0/6
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface GigabitEthernet0/29
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/30
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/31
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/32
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/33
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet0/34
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet0/35
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet0/36
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet0/37
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/38
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/39
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/40
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/41
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/42
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/43
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/44
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/45
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/46
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/47
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/48
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/49
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface GigabitEthernet0/50
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/51
!
interface GigabitEthernet0/52
!
interface Vlan1
ip address 10.0.1.1 255.255.0.0
ip helper-address 10.0.2.1
!
interface Vlan2
ip address 10.254.1.1 255.255.0.0
ip helper-address 10.0.2.1
!
interface Vlan20
ip address 10.1.0.10 255.255.0.0
ip helper-address 10.1.1.1
!
interface Vlan21
no ip address
!
Answer : Catalyst 3560G VLANs, IP Helper-Address, and Windows DHCP Servers
Try this:
int g0/29
switchport trunk allowed vlan 1,2
This will allow only VLANs 1 and 2 on the trunk.
Random Solutions
Install LDAP openfire (UserNotFoundException)
post Netware 6.5 sp4a install -no startup
Lotus Notes VPN problems started when Cisco PIX 506E replaced by ASA 5505
DNS Forwarder
Convert packet to byte (Connection Status)
Pix dilemma
Actiontek GT701-WG DSL Modem on Static IP with NAT Off, DHCP Off, Wireless OFF
Strange home LAN problem using Win XP pro and a linksys WRT54G wireless router
problem trying to tftpdnld a new router ios to a corrupted router
Snoop Question