Question : Cable internet and Cisco router

Ok,

So I have no clue how to do this and it's been thrown at me.  We had a router that used a T1 apparently and behind the router is a PIX515.  I did a show run on the router to see the current config.  Can I use the existing serial port controller for the new cable line or should I put it on FE0/1?  We got these IP's from Comcast:

173.13.19.81
255.255.255.248

GW:  173.13.19.86

How do I config the router for this new connection?  I know all I have to do on the PIX is change the old WAN IP's to the new ones.  But the router.....

Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
Building configuration...
 
Current configuration : 1343 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname troy-inet-rtr
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip domain name hbpogroup.com
!
username admin privilege 15 secret 5 $1$n6GG$2g9X5xzQsQvYWSrlH1fes1
!
!
!
interface FastEthernet0/0
 description PIX Connect
 ip address 216.234.116.121 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0
 description Iserv Connect
 ip address 216.234.103.150 255.255.255.252
 encapsulation ppp
!
ip classless
ip route 0.0.0.0 0.0.0.0 216.234.103.149
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 216.234.116.120 0.0.0.7
!
control-plane
!
banner login ^C
HBPO North America
Authorized Users Only!
^C
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
!
end

Answer : Cable internet and Cisco router

It's not so much that something is *wrong* on the Comcast box as that it isn't set up correctly for your application.  Did you ask Comcast to put the device in bridge mode so that you can use the public IPs on the LAN?  If so and they were unable to assist further, try the following:

Plug a computer into one of the other LAN ports of the Comcast box and get into the web management interface on the unit.  Go to the "SMC Firewall" setting and select "Disable Firewall for True Static IP Subnet Only" and see if that gets everything up and running.

Many others have made this configuration work, so it's just a matter of hammering out the details.  Shouldn't take too long to figure out where the wrench in the gears is.
Random Solutions  
 
programming4us programming4us