Question : Cisco Router help- should be easy 2821 router

I have 2 2821 advanced IP service routers that I just bought for a new network. I'm going to put HSRP on them so let's focus on one for now.
I had them working then the network scheme changed and I reset the routers back to factory to reprogram.

Here's the problem:

I setup the router, 2 gig interfaces and i bought a 4 port ethernet adapter for it. I'm not using the adapter until I get the other ports working.

gig int 0/0 is set as the connection to the internet (which is already on a network in my office, it will not be used after we move this router to the new location).
int gig 0/0 ip address 69.xxx.xxx.70 255.255.xxx.xxx  ---public address that we own
int gig 0/1 ip address 192.168.30.1 255.255.255.0 ---internal network I want to setup
ip route 0.0.0.0 0.0.0.0 69.xxx.xxx.65

For some reason, when I add a laptop to my cisco 3560 switch and give it IP 192.168.30.33 and default gateway 192.168.30.1, I cannot ping the internet. I do however get DNS resolution from the internet (I set it up in the config). I can ping internal network and the router from the laptop, just not outside to the internet.

I can ping from the router to the internet and internal network.
Can't ping from the laptop to the internet.

Any ideas? Am I missing something simple?

Here's my running config:


_____________________________________________________________________________________


Current configuration : 3945 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable password 7 075XXXXXXXXXXXXX
!
no aaa new-model
!
resource policy
!
clock timezone pctime -5
ip subnet-zero
!
!
!
ip cef
!
!
ip domain name yourdomain.com
ip name-server 66.XXX.XXX.2
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-806740676
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-806xxxxx
 revocation-check none
 rsakeypair TP-self-signed-806xxxxxx
!
!
crypto pki certificate chain TP-self-signed-806740676
 certificate self-signed 01
  3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 38303637 34303637 36301E17 0D303631 30303631 38303333
  305A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3830 36373430
  36373630 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  9D8A6183 8301297A 6842F119 631BE025 6235A2DF 3D9436AE 66C2FA21 7D4B8DE5 quit
username cbrown privilege 15 password 7 14xxxxxxx5435
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 69.xxx.xxx.70 255.255.xxx.xxx
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.30.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 shutdown
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
 vlan-id dot1q 1
  exit-vlan-config
 !
!
interface Vlan1
 no ip address
!
interface Vlan30
 no ip address
!
ip classless
ip route 0.0.0.0 0.0.0.0 69.xxx.xxx.65
ip route 69.xxx.xxx.64 255.255.xxx.xxx GigabitEthernet0/0
ip route 192.168.30.0 255.255.255.0 GigabitEthernet0/1
!
ip dns server
!
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
banner login ^C
----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device. This

feature requires the one time use, initial credentials, of username "cisco"
with password "cisco".

-----------------------------------------------------------------------
^C
!
line con 0
 exec-timeout 30 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

Answer : Cisco Router help- should be easy 2821 router

You need to configure nat

access-list 1 permit 192.168.30.0 0.0.0.255

ip nat inside source list 1 interface GigabitEthernet0/0 overload


int GigabitEthernet0/0
ip nat outside

GigabitEthernet0/0
ip nat inside
Random Solutions  
 
programming4us programming4us