Question : CISCO DHCP POOL AND DEVICE ISSUES

I have a Cisco 3845 that is connected to a Cisco 4507R. I have dual DHCP pools setup. One for VOice one for Data. Data is on the Native VLAN 1 and Voice goes to Vlan2. I am not able to get any devices to talk or pull an IP Address from the ROuter. Can someone help me understand why?

Building configuration...

Current configuration : 3096 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 3845_BAKE
!
boot-start-marker
boot-end-marker
!
!card type command needed for slot 1
logging buffered 51200 warnings
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.15.1 10.10.15.100
ip dhcp excluded-address 10.10.14.1 10.10.14.100
!        
ip dhcp pool dhcp-phones
   network 10.10.15.0 255.255.255.0
   default-router 10.10.15.1
   dns-server 10.10.22.199
!
ip dhcp pool data
   network 10.10.14.0 255.255.255.0
   default-router 10.10.14.1
   dns-server 10.10.22.199
!
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!        
!
!
!
!
!
crypto pki trustpoint TP-self-signed-2703395021
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2703395021
 revocation-check none
 rsakeypair TP-self-signed-2703395021
!
!
username cisco privilege 15 secret 5 $1$h18f$RMj62jSsKiMvUwkkxYtkz/
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!        
interface Tunnel0
 ip address 10.32.1.1 255.255.0.0
 tunnel source 24.199.62.237
 tunnel destination 24.199.62.236
!
interface GigabitEthernet0/0
 description Trunk_to_Switch
 no ip address
 duplex full
 speed 1000
 media-type rj45
!
interface GigabitEthernet0/0.1
 description Data_VLAN
 encapsulation dot1Q 1 native
 ip address 10.10.14.1 255.255.255.0
!
interface GigabitEthernet0/0.2
 description Voice_VLAN
 encapsulation dot1Q 2
 ip address 10.10.15.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 duplex full
 speed 100
 media-type rj45
!
interface IDS-Sensor2/0
 no ip address
 shutdown
 hold-queue 60 out
!
interface Analysis-Module3/0
 no ip address
 shutdown
 hold-queue 60 out
!
router eigrp 3
 network 10.10.0.0 0.0.255.255
 network 10.0.0.0
 no auto-summary
!
ip default-gateway 24.199.62.233
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 25 permit 10.0.0.0 0.255.255.255
!
!
!
!
control-plane
!
!
!
!
!
!        
!
!
!
banner login ^CCCC
-----------------------------------------------------------------------
This system is for Authorized use only. If unauthorized, please leave
Now.

AUTHORIZED ONLY PROCEED!
-----------------------------------------------------------------------
^C
!
line con 0
 login local
 stopbits 1
line 130
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line aux 0
 stopbits 1
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

This is the config for the Switch

3845_BAKE#sh run
Building configuration...

Current configuration : 4756 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot system flash bootflash:cat4000-i5s-mz.122-25.EWA8.bin
boot-end-marker
!
!
redundancy
 mode sso
 main-cpu
  auto-sync standard
!
no aaa new-model
ip subnet-zero
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface FastEthernet3/1
!
interface FastEthernet3/2
!        
interface FastEthernet3/3
 switchport voice vlan 2
!
interface FastEthernet3/4
!
interface FastEthernet3/5
!
interface FastEthernet3/6
!
interface FastEthernet3/7
!
interface FastEthernet3/8
!
interface FastEthernet3/9
!
interface FastEthernet3/10
!
interface FastEthernet3/11
!
interface FastEthernet3/12
!
interface FastEthernet3/13
!        
interface FastEthernet3/14
!
interface FastEthernet3/15
!
interface FastEthernet3/16
!
interface FastEthernet3/17
!
interface FastEthernet3/18
!
interface FastEthernet3/19
!
interface FastEthernet3/20
!
interface FastEthernet3/21
!
interface FastEthernet3/22
!
interface FastEthernet3/23
!
interface FastEthernet3/24
!
interface FastEthernet3/25
!
interface FastEthernet3/26
!
interface FastEthernet3/27
!
interface FastEthernet3/28
!
interface FastEthernet3/29
!
interface FastEthernet3/30
!
interface FastEthernet3/31
!
interface FastEthernet3/32
 switchport voice vlan 2
 speed 100
 duplex full
!
interface FastEthernet3/33
!
interface FastEthernet3/34
!
interface FastEthernet3/35
!
interface FastEthernet3/36
!
interface FastEthernet3/37
!
interface FastEthernet3/38
!
interface FastEthernet3/39
!
interface FastEthernet3/40
!
interface FastEthernet3/41
!
interface FastEthernet3/42
!
interface FastEthernet3/43
!
interface FastEthernet3/44
!
interface FastEthernet3/45
!
interface FastEthernet3/46
!        
interface FastEthernet3/47
!
interface FastEthernet3/48
!
interface FastEthernet4/1
!
interface FastEthernet4/2
!
interface FastEthernet4/3
!
interface FastEthernet4/4
!
interface FastEthernet4/5
!
interface FastEthernet4/6
!
interface FastEthernet4/7
!
interface FastEthernet4/8
!
interface FastEthernet4/9
!
interface FastEthernet4/10
!
interface FastEthernet4/11
!
interface FastEthernet4/12
!
interface FastEthernet4/13
!
interface FastEthernet4/14
!
interface FastEthernet4/15
!
interface FastEthernet4/16
!
interface FastEthernet4/17
!
interface FastEthernet4/18
!
interface FastEthernet4/19
!
interface FastEthernet4/20
!
interface FastEthernet4/21
!        
interface FastEthernet4/22
!
interface FastEthernet4/23
!
interface FastEthernet4/24
!
interface FastEthernet4/25
!
interface FastEthernet4/26
!
interface FastEthernet4/27
!
interface FastEthernet4/28
!
interface FastEthernet4/29
!
interface FastEthernet4/30
!
interface FastEthernet4/31
!
interface FastEthernet4/32
!
interface FastEthernet4/33
!
interface FastEthernet4/34
!
interface FastEthernet4/35
!
interface FastEthernet4/36
!
interface FastEthernet4/37
!
interface FastEthernet4/38
!
interface FastEthernet4/39
!
interface FastEthernet4/40
!
interface FastEthernet4/41
!
interface FastEthernet4/42
!
interface FastEthernet4/43
!
interface FastEthernet4/44
!        
interface FastEthernet4/45
!
interface FastEthernet4/46
!
interface FastEthernet4/47
!
interface FastEthernet4/48
!
interface GigabitEthernet5/1
 description TRUNK LINE ROUTER
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 speed 1000
 duplex full
!
interface GigabitEthernet5/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1-3
 speed 100
 duplex full
!
interface GigabitEthernet5/3
!
interface GigabitEthernet5/4
!
interface GigabitEthernet5/5
!
interface GigabitEthernet5/6
!
interface GigabitEthernet5/7
!
interface GigabitEthernet5/8
!
interface GigabitEthernet5/9
!
interface GigabitEthernet5/10
!
interface GigabitEthernet5/11
!
interface GigabitEthernet5/12
!
interface GigabitEthernet5/13
!
interface GigabitEthernet5/14
!        
interface GigabitEthernet5/15
!
interface GigabitEthernet5/16
!
interface GigabitEthernet5/17
!
interface GigabitEthernet5/18
!
interface GigabitEthernet5/19
!
interface GigabitEthernet5/20
!
interface GigabitEthernet5/21
!
interface GigabitEthernet5/22
!
interface GigabitEthernet5/23
!
interface GigabitEthernet5/24
!
interface Vlan1
 description Data VLAN
 ip address 10.10.14.10 255.255.255.0
!
interface Vlan2
 description Voice VLAN
 ip address 10.10.15.10 255.255.255.0
!
interface Vlan3
 no ip address
!
ip http server
!
!
!
!
!
line con 0
 stopbits 1
line vty 0 4
 no login
!
!
end

Answer : CISCO DHCP POOL AND DEVICE ISSUES

It has to do with ip helper addresses missing.  However, since both devices are L3, you don't need to use your 3845 as a router-on-a-stick.  You can use the switch to do inter-VLAN-routing.

So, enable DHCP on the switch and disable it on the router.  Or, convert the link from the switch to the router to a different L3 subnet and add IP helper addresses on the switch VLAN interfaces that point to the new router interface IP address.  Of course, make sure to change the default gateways accordingly.  Those should be the switch VLAN interface IPs.
Random Solutions  
 
programming4us programming4us