Question : Pix 501 Remote Access VPN Issue

Hello guys-

Here's the sceneario... I'm trying to connect work to home via ipsec vpn using the pix 501 and the cisco vpn client.

I've tried 8 million things nothigns worked.  

Right now i am attempting to connect form home with no dice using the vpn client 4.4d

I know it works cause i can vpn to a different pix box from home.

Here's the config.... :)

Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password @@@@@
passwd @@@@@@
hostname pixfirewall
domain-name doyleswholesale.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group service as400 tcp
  port-object eq ftp
  port-object eq ftp-data
  port-object eq telnet
  port-object eq https
  port-object eq www
object-group service Domain tcp
  port-object eq ftp
  port-object range 3333 3333
  port-object eq https
  port-object eq www
  port-object eq smtp
access-list outside_access_in permit tcp any host @@@.239.225.194 object-group as400
access-list outside_access_in permit tcp any host @@@.239.225.195 object-group Domain
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 101 permit ip host 192.168.1.2 192.168.2.0 255.255.255.0
access-list 101 permit ip host 192.168.1.1 192.168.2.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.2.0 255.255.255.0
pager lines 24
logging on
logging console alerts
mtu outside 1500
mtu inside 1500
ip address outside @@@.239.225.200 255.255.255.0
ip address inside 192.168.1.4 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool Default 192.168.2.1-192.168.2.254
pdm location 192.168.1.1 255.255.255.255 inside
pdm location 192.168.1.2 255.255.255.255 inside
pdm location 192.168.2.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) @@@.239.225.195 192.168.1.1 netmask 255.255.255.255 0 0
static (inside,outside) @@@.239.225.194 192.168.1.2 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 @@@.239.225.193 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup DoylesVPN address-pool Default
vpngroup DoylesVPN idle-time 1800
vpngroup DoylesVPN password ********
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:54e49201fdc96e7c4ef6e185e15a0e96
: end
[OK]

Answer : Pix 501 Remote Access VPN Issue

ISAKMP: transform 1, ESP_AES
ISAKMP:   attributes in transform:
ISAKMP:      authenticator is HMAC-SHA
ISAKMP:      key length is 256 <<<---
ISAKMP:      encaps is 1
ISAKMP:      SA life type in seconds
ISAKMP:      SA life duration (VPI) of  0x0 0x20 0xc4 0x9b
ISAKMP (0): atts are acceptable.
ISAKMP (0): bad SPI size of 2 octets!
ISAKMP : Checking IPSec proposal 3

ISAKMP: transform 1, ESP_AES
ISAKMP:   attributes in transform:
ISAKMP:      authenticator is HMAC-MD5
ISAKMP:      key length is 128 <<<---
ISAKMP:      encaps is 1
ISAKMP:      SA life type in seconds
ISAKMP:      SA life duration (VPI) of  0x0 0x20 0xc4 0x9b IPSEC(validate_proposal): transform proposal (prot 3, trans 12, hmac_alg 1) not supported

It looks like the client does not support AES-256

suggest changing your transform-set to 128 bit default aes
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-AES-256-SHA

TO:
crypto ipsec transform-set ESP-AES-SHA esp-aes esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-AES-SHA
Random Solutions  
 
programming4us programming4us