Question : Help with VLAN configuration across multiple Cisco 3560 switches

I've been struggling through segmenting our network with VLANs for an upcoming Mitel VoIP installation.  So far I haven't broken anything...

Was just wondering if someone could look over my config files for two switches and make suggestions.  Switch one is our main office Gigabit switch that will be used for just data.  I figured it would be best to use this is as the main switch and the one doing the routing.  

Switch two, another 3560 is trunked to the main switch.  I think I got the 802.1q trunking right on this one.  I was trying to test with a laptop with a manually entered IP / gateway, but the port just stayed orange and I couldn't even ping the VLAN interfaces.

 I would like it if both VLANs are accessible on all switches, in case we find a need to plug a phone into the "data" switch, or if we find a need to plug a data device into a phone or phone port.

Some more information on my setup:
-Switch 1 (data) IP is: 10.0.0.30
-Switch 2 (voice) IP is: 10.0.0.5 trunked to GigabitEthernet0/48 of Switch 1
-Switch 3 (shop voice, still in the box):  not configured yet, but will trunked to GigabitEthernet0/51 of Switch 1
-Switch 4 (2nd data switch):  10.0.0.31 trunked to GigabitEthernet0/47 of Switch 1
-Juniper firewall out to internet:  10.0.0.15
-DC / DHCP server: 10.0.0.6

I was wanting VLAN 1, the default VLAN that is currently operational, to remain for the data, and VLAN2 for voice.  Is the VLAN2 interface the same on both (all) switches?  i.e. 10.0.1.1, or should switch 1 be 10.0.1.1 and switch 2 be 10.0.1.2, etc?  Also, does the QoS look OK for a generic VoIP installation (assuming Mitel doesn't have any odd requirements)?  Anything that looks odd probably is.  We were using the switches out of the box until now.

Thanks so much in advance!
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
149:
150:
151:
152:
153:
154:
155:
156:
157:
158:
159:
160:
161:
162:
163:
164:
165:
166:
167:
168:
169:
170:
171:
172:
173:
174:
175:
176:
177:
178:
179:
180:
181:
182:
183:
184:
185:
186:
187:
188:
189:
190:
191:
192:
193:
194:
195:
196:
197:
198:
199:
200:
201:
202:
203:
204:
205:
206:
207:
208:
209:
210:
211:
212:
213:
214:
215:
216:
217:
218:
219:
220:
221:
222:
223:
224:
225:
226:
227:
228:
229:
230:
231:
232:
233:
234:
235:
236:
237:
238:
239:
240:
241:
242:
243:
244:
245:
246:
247:
248:
249:
250:
251:
252:
253:
254:
255:
256:
257:
258:
259:
260:
261:
262:
263:
264:
265:
266:
267:
268:
269:
270:
271:
272:
273:
274:
275:
276:
277:
278:
279:
280:
281:
282:
283:
284:
285:
286:
287:
288:
289:
290:
291:
292:
293:
294:
295:
296:
297:
298:
299:
300:
301:
302:
303:
304:
305:
306:
307:
308:
309:
310:
311:
312:
313:
314:
315:
316:
317:
318:
319:
320:
321:
322:
323:
324:
325:
326:
327:
328:
329:
330:
331:
332:
333:
334:
335:
336:
337:
338:
339:
340:
341:
342:
343:
344:
345:
346:
347:
348:
349:
350:
351:
352:
353:
354:
355:
356:
357:
358:
359:
360:
361:
362:
363:
364:
365:
366:
367:
368:
369:
370:
371:
372:
373:
374:
375:
376:
377:
378:
379:
380:
381:
382:
383:
384:
385:
386:
387:
388:
389:
390:
391:
392:
393:
394:
395:
396:
397:
398:
399:
400:
401:
402:
403:
404:
405:
406:
407:
408:
409:
410:
411:
412:
413:
414:
415:
416:
417:
418:
419:
420:
421:
422:
423:
424:
425:
426:
427:
428:
429:
430:
431:
432:
433:
434:
435:
436:
437:
438:
439:
440:
441:
442:
443:
444:
445:
446:
447:
448:
449:
450:
451:
452:
453:
454:
455:
456:
457:
458:
459:
460:
461:
462:
463:
464:
465:
466:
467:
468:
469:
470:
471:
472:
473:
474:
475:
476:
477:
478:
479:
480:
481:
482:
483:
484:
485:
486:
487:
488:
489:
490:
491:
492:
493:
494:
495:
496:
497:
498:
499:
500:
501:
502:
503:
504:
505:
506:
507:
508:
509:
510:
511:
512:
513:
514:
515:
516:
517:
518:
519:
520:
521:
522:
523:
524:
525:
526:
527:
528:
529:
530:
531:
532:
533:
534:
535:
536:
537:
538:
539:
540:
541:
542:
543:
544:
545:
546:
547:
Switch 1 (GWI_GigE_1):
 
Current configuration : 5817 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname GWI_GigE_1
!
enable secret 5 $1$lKRM$IT3A93g2lyfogPUlAq9dA0
!
no aaa new-model
ip subnet-zero
ip routing
!
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface GigabitEthernet0/29
!
interface GigabitEthernet0/30
!
interface GigabitEthernet0/31
!
interface GigabitEthernet0/32
!
interface GigabitEthernet0/33
!
interface GigabitEthernet0/34
!
interface GigabitEthernet0/35
!
interface GigabitEthernet0/36
!
interface GigabitEthernet0/37
!
interface GigabitEthernet0/38
!
interface GigabitEthernet0/39
!
interface GigabitEthernet0/40
!
interface GigabitEthernet0/41
!
interface GigabitEthernet0/42
!
interface GigabitEthernet0/43
!
interface GigabitEthernet0/44
!
interface GigabitEthernet0/45
!
interface GigabitEthernet0/46
!
interface GigabitEthernet0/47  ## Connects to 2nd data switch ##
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/49
interface GigabitEthernet0/51
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/52
!
interface Vlan1
 ip address 10.0.0.30 255.255.255.0
!
interface Vlan2
 ip address 10.0.1.1 255.255.255.0
!
ip default-gateway 10.0.0.15
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.15
ip http server
!
!
control-plane
!
 
Switch 2 (Voice):
Building configuration...
 
Current configuration : 14088 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname GWIVoIP
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$EhoP$H5ygH5vq.DvCiBguoezfP1
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
ip name-server 10.0.0.6
!
!
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR
 enrollment selfsigned
 serial-number
 revocation-check none
 rsakeypair HTTPS_SS_CERT_KEYPAIR
!
!
crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR
 certificate self-signed 01
  30820258 308201C1 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  3D311130 0F060355 04031308 47574956 6F49502E 3128300F 06035504 05130839
  33343335 45383030 1506092A 864886F7 0D010902 16084757 49566F49 502E301E
  170D3933 30333031 30303031 32385A17 0D323030 31303130 30303030 305A303D
  3111300F 06035504 03130847 5749566F 49502E31 28300F06 03550405 13083933
  34333545 38303015 06092A86 4886F70D 01090216 08475749 566F4950 2E30819F
  300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100D3C4 7DF2D5BD
  C60AC6A4 6FDEAACC F239110F 32C15637 BDB46C20 121D707C 86DD7583 1611AF93
  39588B2C 93231CFD 69FD21D8 0B9C2981 DF1DACEE 522FA473 06C2106A 183F86C7
  4F4E702D D58E1ED7 8F43FCA2 156400F0 A9504C38 705E3818 34E7F301 BE4C2834
  0DC10215 4428793C 7CBE881E 8F78A3B7 4423819C DD9ED577 789B0203 010001A3
  68306630 0F060355 1D130101 FF040530 030101FF 30130603 551D1104 0C300A82
  08475749 566F4950 2E301F06 03551D23 04183016 8014F1F3 C0AD9BEF 66C79AA0
  49D32E35 1F0F575D 8856301D 0603551D 0E041604 14F1F3C0 AD9BEF66 C79AA049
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/7
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/8
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/9
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/10
 switchport access vlan dynamic
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/11
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/12
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/13
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/15
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/16
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/17
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/18
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/19
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/20
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/21
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
 
..........
 
interface FastEthernet0/45
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/46
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/47
 switchport access vlan dynamic
 switchport mode access
 switchport voice vlan 2
 switchport priority extend trust
 no mdix auto
 spanning-tree portfast
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 priority-queue out
 mls qos trust cos
 auto qos voip trust
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
 ip address 10.0.0.5 255.255.255.0
!
interface Vlan2
 no ip address
 ip helper-address 10.0.0.6
!
ip default-gateway 10.0.0.30
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.30
ip http server
ip http secure-server
!
!
control-plane
 
(Switch 3 and 4 omitted for now)

Answer : Help with VLAN configuration across multiple Cisco 3560 switches

>I have a laptop connected to fa0/3 with IP 10.0.1.20, default GW 10.0.1.1, 255.255.255.0

That port is a trunk. You don't usually trunk to a PC.

Try this:

1:
2:
int fa0/3
switchport mode access
Random Solutions  
 
programming4us programming4us