Question : Build VOIP Network using 1751/1760 routers - without spending a lot of money

Hello,
I am interested in:
-connecting 3 houses with few Cisco IP phones in each
-the connection between those houses needs to be via the internet
-the internet is reached by ADSL/CABLE modems, so by an ethernet port to the modem
-no classic telephone service needs to be involved - calls between houses must be free

Please tell me how cheapest I can reach all of this using those Cisco products.
Please tell me also what products I need.
Please tell me, without details, how those devices need to be connected with each others
Please explain me the configuration and the connection in details

And since 1700 routers are EoL and EoS, please tell me whether there is still any cheap solution using some other cheap hardware still in sale and support.
The main house would be in Poland, one or two houses in Italy and one in Romania.


Answer : Build VOIP Network using 1751/1760 routers - without spending a lot of money

You might get more if i show you my config
version 12.4
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname Worthing1
!
boot-start-marker
warm-reboot count 10 uptime 10
boot-end-marker
!
logging userinfo
logging buffered 4096 debugging
no logging console
no logging monitor
enable password 7 0825494B191D171605
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
!
resource policy
!
voice-card 2
!
voice-card 3
!
no ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool lan
   import all
   network 172.25.0.0 255.255.255.0
   default-router 172.25.0.1
   dns-server 172.25.0.1 195.186.1.108 195.186.4.108
   option 150 ip 172.25.0.1
!
!

ip name-server 194.74.65.69
ip name-server 194.72.9.34
ip name-server 195.186.1.108
ip name-server 4.2.2.1
!
!
!
voice rtp send-recv
!
voice service pots
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 h323
!
!
!
voice class codec 100
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g723r53
 codec preference 4 g729r8
 codec preference 5 g726r32
 codec preference 6 g728
!
!
!
voice class h323 100
 h225 timeout tcp establish 1
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^9/ //
!
!
!

!
voice translation-profile sip

 translate called 1
!

!
!
!
application
 service operator flash:its-CISCO.2.0.1.0.tcl
  param num-allow2 07786855766
  paramspace english index 0
  paramspace english language en
  param aa-pilot 100
  paramspace english location flash:
 
 !
!
!

username greg privilege 15 secret blah
!
!
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
!
crypto isakmp policy 2
 hash md5
 authentication pre-share
 group 5
!
crypto isakmp policy 3
 authentication pre-share
crypto isakmp key blahblahblah address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
 mode transport
crypto ipsec transform-set COMP esp-des esp-md5-hmac comp-lzs
!
crypto ipsec profile SDM_Profile1
 set transform-set COMP ESP-3DES-SHA
!
!
!
!
!
interface Tunnel0
 description $FW_INSIDE$
 bandwidth 1000
 ip address 172.25.11.3 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication DMVPN_NW
 ip nhrp map multicast <>
 ip nhrp map 172.25.11.1 <>
 ip nhrp network-id 9999
 ip nhrp holdtime 360
 ip nhrp nhs 172.25.11.1
 ip nhrp registration no-unique
 ip virtual-reassembly
 ip tcp adjust-mss 1360
 delay 1000
 tunnel source Dialer1
 tunnel mode gre multipoint
 tunnel key 99
 tunnel protection ipsec profile SDM_Profile1
!
interface ATM0/0
 mtu 1500
 no ip address
 no ip redirects
 ip virtual-reassembly
 no atm ilmi-keepalive
 dsl operating-mode auto
 dsl enable-training-log
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0/0
 ip address 172.25.15.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 speed auto
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface Vlan1
 ip address 172.25.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 
interface Dialer1
 ip address negotiated
 ip access-group 1 in
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname blah
 ppp chap password 7 blah
 ppp multilink
!
router eigrp 12
 network 172.25.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip dns server
!
ip http server
ip http secure-server
ip http path flash:
ip nat translation timeout 3600
ip nat translation tcp-timeout 3600
ip nat translation udp-timeout 3600
ip nat translation max-entries 3600
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 172.25.0.2 80 interface Dialer1 80
ip nat inside source static tcp 172.25.0.2 21 interface Dialer1 21
ip nat inside source static tcp 172.25.0.2 554 interface Dialer1 554

!
logging trap debugging
logging 172.25.0.200
access-list 1 permit any
access-list 101 permit tcp any any

dialer-list 1 protocol ip permit
snmp-server community public RO
!
tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sbn
tftp-server flash:P0030702T023.sb2
tftp-server flash:RingList.xml
tftp-server flash:Ring1.raw
tftp-server flash:Ring2.raw
tftp-server flash:Ring3.raw
tftp-server flash:Ring4.raw
tftp-server flash:Ring5.raw
tftp-server flash:Ring6.raw
tftp-server flash:Ring7.raw
tftp-server flash:Analog1.raw
tftp-server flash:Analog2.raw
tftp-server flash:AreYouThere.raw
tftp-server flash:Drums1.raw
!
control-plane
!
!
!
!
voice-port 3/0
 description fxs-port greg
 station-id number 101
 caller-id enable
!
voice-port 3/1
 caller-id enable 102
!

!
dial-peer voice 1001 pots
 destination-pattern 102
 port 3/1
!
dial-peer voice 1 voip
 destination-pattern 3010
 session target ipv4:172.25.10.1
 codec g711ulaw
!
dial-peer voice 2 voip
 preference 7
 destination-pattern 1020
 session target ipv4:172.25.5.1
 codec g711ulaw
!
dial-peer voice 3 voip
 destination-pattern 101
 session target ipv4:172.25.10.1
 incoming called-number 1010
 codec g711ulaw
!
dial-peer voice 9 pots
 description phone1
 destination-pattern 101
 port 3/0
!
!
gateway
 timer receive-rtp 1200
!
sip-ua
 authentication username blah password blah
 retry invite 4
 retry response 3
 retry bye 2
 retry cancel 2
 retry register 5
 timers notify 1000
 timers register 1000
 registrar dns:sip.myphone.ge expires 3600
 sip-server dns:sip.myphone.ge
!
!

!
!

!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 blah
line vty 5 15
 password 7 blah
!
ntp clock-period 17182105
ntp server 79.99.122.29
ntp server 87.232.1.41
ntp server 84.54.128.8
ntp server 130.88.203.64
end
not too much removed!
Random Solutions  
 
programming4us programming4us