Question : VOIP * Static VPN from Home to a Pix 515 or Windows VPN Server

I am able to VPN into the office by connecting to our Pix 515 or our Windows VPN Server.  Everything works great, no problems.  I want to put in something "hardware" that will connect to one of the two VPN Servers without the need of a computer or client software to make the connection.

I want to be able to plug in a Cisco 7961 IP Phone to this device and be connected to my office network.  I know I could use a softphone but that really isn't an option.

Thanks in advance!

Answer : VOIP * Static VPN from Home to a Pix 515 or Windows VPN Server

Here is a good sample ASA config. Look for the arrows to show were you need to add input.


 ASA Version 7.2(3)
!
hostname
domain-name .com
enable password xxxxxxxxxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address
!
interface Vlan2
 nameif outside
 security-level 0
 ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd xxxxxxxxx encrypted
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
 domain-name .com
access-list 101 extended permit ip
access-list nonat extended permit ip
pager lines 24
logging enable
logging monitor debugging
logging buffered notifications
logging asdm notifications
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map remote 60 set transform-set myset
crypto map newmap 10 match address orland
crypto map newmap 10 set peer
crypto map newmap 10 set transform-set myset
crypto map newmap 40 ipsec-isakmp dynamic remote
crypto map newmap interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 255.255.255.0 outside
ssh timeout 30
console timeout 0
management-access inside

!
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect xdmcp
  inspect icmp
  inspect icmp error
!
service-policy global_policy global
username xxxxxx password xxxxxxxxx encrypted privilege 7
tunnel-group type ipsec-l2l
tunnel-group ipsec-attributes
 pre-shared-key
prompt hostname context
: end
Random Solutions  
 
programming4us programming4us