Question : How do I configure Voice VLAN's for Cisco 2960 switch?

I should preface this by saying I know next to nothing about Switches! This implementation was originally constructed and rolled out by a 3rd Party but since then we have had a switch failure and did not have backups. I was able to get data back up and running with the below config, but its apparentely wrong because my on-site Cisco 7960 phones refuse to pull an ip address. It appears that I may have configured the vlan's improperly. Can anyone take a look and throw out some inputs? Thanks!
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
User Access Verification
 
VoiceSwitch#sh run
Building configuration...
 
Current configuration : 2630 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname VoiceSwitch
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 switchport access vlan 2
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan 2
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan 2
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan 10
!
interface FastEthernet0/5
 switchport access vlan 10
!
interface FastEthernet0/6
 switchport access vlan 10
!
interface FastEthernet0/7
 switchport access vlan 10
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/8
 switchport access vlan 10
!
interface FastEthernet0/9
 switchport access vlan 10
!
interface FastEthernet0/10
 switchport access vlan 10
!
interface FastEthernet0/11
 switchport access vlan 10
!
interface FastEthernet0/12
 switchport access vlan 10
 switchport voice vlan 3
 spanning-tree portfast
!
interface FastEthernet0/13
 switchport access vlan 10
!
interface FastEthernet0/14
 switchport access vlan 10
!
interface FastEthernet0/15
 switchport access vlan 10
!
interface FastEthernet0/16
 switchport access vlan 10
!
interface FastEthernet0/17
 switchport access vlan 10
 switchport voice vlan 3
 spanning-tree portfast
!
interface FastEthernet0/18
 switchport access vlan 10
!
interface FastEthernet0/19
 switchport access vlan 10
!
interface FastEthernet0/20
 switchport access vlan 10
!
interface FastEthernet0/21
 switchport access vlan 10
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/22
 switchport access vlan 10
!
interface FastEthernet0/23
 switchport access vlan 10
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/24
 switchport access vlan 10
 switchport voice vlan 2
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description Voice_Server
 ip address 20.20.2.254 255.255.255.0
!
interface Vlan3
 description Voice
 ip address 20.20.3.1 255.255.255.0
 ip helper-address 20.20.2.10
!
interface Vlan10
 description Data
 no ip address
!
ip http server
!
control-plane
!
!
!
end
 
VoiceSwitch#

Answer : How do I configure Voice VLAN's for Cisco 2960 switch?

Cisco TAC ended up resolving this for me. I neeed to configure trunking on the switch port that interfaced with the router's gigabit ethernet ports. So basically I needed this:

interface FastEthernet0/21
 switchport mode trunk

Thank you all for contributing to this!
Random Solutions  
 
programming4us programming4us