Question : How to setup IP VRF on Cisco 7200

I have a few customers who want a service that is built with IP VRF (i believe thats what I need to use). They want to have the ability to have their own network over my network, with IP addresses of their choice and will not have to worry about over laping with other customers because of the (IP VRF) virtual router each with its own routing table (configured on my 7206). They do not want internet connectivity and also do not want other customers traffic to have the ability to leak onto their ptp lines. I do not want encryption, and I not interested in MPLS at this time (unless what I am asking for is MPLS, then I would be).

I've read online and even checked out some books but cannot find much information on this topic. Cisco's site wasnt much help either.

Can anyone help me out with a basic configuration to get me started?

Thanks

Answer : How to setup IP VRF on Cisco 7200

(Apologies, as I'm going to text out a flowchart)

Is this a new VPN?  If not, determine the VPN ID and go to ZZ.
  Assign a VPN ID (let's say 501).

ZZ: Determine the appropriate router to build this port on.
Is this router configured for this VPN?  If so, go to ZY.
  If not, do the following (substitute your ASN for XYZ):

conf t
ip vrf
rd XYZ:
route-target XYZ:VPNID
router bgp XYZ
address-family ipv4 vrf
redistribute connected route-map mpls-conn-bgp
redistribute static
!
!add if the prefix-list hasn't been configured on this router yet.
ip prefix-list no-slash32 permit 0.0.0.0/0 le 31
!
!add if the route-map hasn't been configured on this router yet.
route-map mpls-conn-bgp permit 20
 match ip addr prefix no-slash32
!
route-map mpls-conn-bgp deny 40
!

ZY: Configure the port in the VRF.

conf t
int MediaX/Y
ip vrf forwarding
(usual interface config, no uRPF filter unless requested)

ZX: Are static routes requested for this port?  If not, go to ZW.

conf t
ip route vrf [] []
!
! Use interface whenever possible; use interface and next hop on all Ethernet routes.

ZW: Is this port going to be used for a default route?  If not, done.

conf t
router bgp 11457
address-family ipv4 vrf
network 0.0.0.0 mask 0.0.0.0

Random Solutions  
 
programming4us programming4us