Question : Using GRE Tunnel as leased line Backup

I have been trying to set this up in a lab environment to deploy in to the field.  I have routers connected back to back with a serial interface.  Head office Leased lines to 2 branches.  I also have the internet connected to the ethernet interfaces.  I've built the leased lines and I was able to bring up the GRE tunnels.  I haven't applied any IPSEC yet.  

Here's my issue, when I admin shut my serial interface going to the branch, the GRE tunnel over the internet also fails and goes to an up/down state.  Why is this happening?  Isn't the serial interface separate from a configured tunnel interface going over the internet?  
Code Snippet:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
149:
150:
151:
152:
153:
154:
155:
156:
157:
158:
159:
160:
161:
162:
163:
164:
165:
166:
167:
168:
169:
170:
Home-Office#sh run
Building configuration...
 
Current configuration : 2194 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Home-Office
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 $1$WAs2$KyrXVCTLSj8P9i8rAF6HB.
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password 0 oppor2nity
!
!
!
!
!
!
interface Tunnel101
 description backup tunnel to Backup
 ip address 192.168.0.1 255.255.255.0
 keepalive 3 2
 tunnel source Ethernet3/0
 tunnel destination 64.128.34.45
!
interface Tunnel102
 ip address 192.168.2.1 255.255.255.0
 keepalive 3 2
 tunnel source Ethernet3/0
 tunnel destination x.x.x.43
!
interface Loopback0
 no ip address
!
interface FastEthernet1/0
 ip address 10.1.100.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 description to Branch 1
 ip address 172.16.0.1 255.255.255.252
 ip nat inside
 ip virtual-reassembly
 clock rate 128000
 no dce-terminal-timing-enable
!
interface Serial2/1
 description to Branch 2
 ip address 172.16.1.1 255.255.255.252
 ip nat inside
 ip virtual-reassembly
 shutdown
 clock rate 128000
 no dce-terminal-timing-enable
!
interface Serial2/2
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Serial2/3
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Ethernet3/0
 ip address x.x.x.106 255.255.255.240
 ip nat outside
 ip virtual-reassembly
 full-duplex
!
interface TokenRing3/0
 no ip address
 shutdown
 ring-speed 16
!
router eigrp 100
 redistribute static
 network 10.1.100.0 0.0.0.255
 network 172.16.0.0 0.0.0.3
 network 172.16.1.0 0.0.0.3
 no auto-summary
!
router rip
 network 192.168.0.0
!
ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 x.x.x.97
ip route 10.1.101.0 255.255.255.0 192.168.0.2 100
!
!
ip nat inside source list 130 interface Ethernet3/0 overload
!
access-list 130 permit ip 10.1.0.0 0.0.255.255 any
access-list 130 permit ip 172.16.0.0 0.0.0.3 any
access-list 130 permit ip 172.16.1.0 0.0.0.3 any
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password oppor2nity
 login
!
!
end
 
Home-Office#
 
Home-Office#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet1/0            10.1.100.1      YES manual up                    up
Serial2/0                  172.16.0.1      YES manual up                    up
Serial2/1                  172.16.1.1      YES manual administratively down down  <<< I shut this
Serial2/2                  unassigned      YES NVRAM  administratively down down
Serial2/3                  unassigned      YES NVRAM  administratively down down
Ethernet3/0                x.x.x.106     YES NVRAM  up                    up
TokenRing3/0               unassigned      YES NVRAM  administratively down down
NVI0                       unassigned      NO  unset  up                    up
Loopback0                  unassigned      YES unset  up                    up
Tunnel101                  192.168.0.1     YES manual up                    up
Tunnel102                  192.168.2.1     YES manual up                    down  <<<< This goes down
Home-Office#

Answer : Using GRE Tunnel as leased line Backup

under the "router eigrp", you should setup route-map for redistribute static to filter out 0.0.0.0 network. this is a typical issue for GRE tunnel.
Random Solutions  
 
programming4us programming4us